Wednesday, August 12, 2009

Xtext 0.7.2 released, but...

I get

Cannot complete the install because one or more required items could not be found.
Software being installed: Xtext Runtime (Incubation) 0.7.2.v200908120607 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908120607)
Missing requirement: Xtext Generator (Incubation) 0.7.2.v200908120607 (org.eclipse.xtext.generator 0.7.2.v200908120607) requires 'bundle org.eclipse.xtend.util.stdlib 0.7.2' but it could not be found
Cannot satisfy dependency:
From: Xtext Runtime (Incubation) 0.7.2.v200908120607 (org.eclipse.xtext.runtime.feature.group 0.7.2.v200908120607)
To: org.eclipse.xtext.generator [0.7.2.v200908120607]



I will investigate that later.

2 comments:

  1. I think you should put such issues into bugzilla.
    http://bugs.eclipse.org

    ReplyDelete
  2. Hi Joheinz,

    that is not a problem with Xtext but with the Update Manager of Eclipse. Please choose the itemis update site and ensure that you checked the 0.7.2 Release of Xtext, MWE and Xpand to be installed. The update manager does not respect dependent plugins when you had already an older version installed and choose "install" instead of "check for updates". You are free to file a bug for Eclipse p2 :-)

    The update site can be found here:
    http://download.itemis.com/updates

    Regards,
    Sebastian

    ReplyDelete